Mikrotik skripta za update obavijest

Vrijeme čitanja: 4 min

Mikrotik, kao i svi ostali mrežni uređaji, jednom kad se podese i rade ispravno, na njih se više ne spaja toliko često. Spaja se kad treba eventualno promijeniti nešto u konfiguraciji ili pogledati logove kada nešto ne radi.

Kako bi onda znao kad je došao novi firmware update za Mikrotik? – Jer nisi lud da se svaki čas spajaš na njega i provjeravaš.

Mikrotik ima jednu odličnu opciju, a to je da možeš napisati neku skriptu za njega i pustiti da skripta radi svoj posao. Upravo takvu jednu skriptu ćemo postaviti u ovom članku – skripta koja provjerava da li ima novi update za Mikrotik i ako ima, neka nam pošalje email s obavijesti o tome!

Zar to nije odlično 😊

Preporučam da skripta samo šalje obavijest o novom update-u, a sve ostale odluke da ipak radimo sami. Jer nije zgodno da Mikrotik automatski instalira novi update pošto nećemo znati koje su promijene i kad je došlo do instalacije, ali ako nešto ne radi dobro, to ćemo vrlo brzo saznati.
Ovako kad dođe samo obavijest o novom update-u, možemo pogledati što donosi novog te na Mikrotik forumu baciti oko da li ima kakvih problema oko njega.

No, dosta pričanja, idemo se baciti na posao …

  • Korišteni uređaj: Mikrotik RB4011igs+5hacq2hnd-in
  • Router OS verzija: 6.48.3
Email postavke

Da bi Mikrotik uopće mogao slati bilo što, potrebno je na njemu prvo podesiti email postavke.

  1. Preduvjet je da imamo neku email adresu koja će služiti za slanje.

    Ne bih tu stavljao svoju privatnu email adresu niti bilo koju drugu koju koristim. Već sam samo za ovu namjenu otvorio novu generičku Gmail adresu, zato to preporučam i ovdje. Bolje da je to odvojeno od svih drugih email adresa.

    Napomena: da bi ovo sve radilo, ta Gmail adresa mora imati smanjenu sigurnost, što je još jedan razlog zašto sam se odlučio za novu posebnu email adresu.

    • Kad si prijavljen u svoj Gmail račun, odeš gore desno na svoj profil i klikneš na Manage your Google Account.
    • Zatim u lijevom izborniku klik na Security.
    • Negdje na sredini stranice pronađi gdje piše Less secure app access i uključi tu opciju.
Prikaz opcija za Gmail - Less secure app

Google često mijenja svoj izgled, pa možda neće izgledati ovako u trenutku dok budeš čitao ovo, ali zapamti da treba uključiti opciju za pristup aplikacijama s manjom sigurnošću.

2. Sad kad imamo email adresu podešenu za slanje, idemo konfigurirati Mikrotik.

Tools > Email

Ovdje je potrebno unijeti Gmail postavke kako bi Mikrotik mogao uspješno slati mailove:

  • Server: imap.gmail.com
  • Port: 587
  • Start TLS: Yes
  • From: tvoja email adresa
  • User: tvoja email adresa
  • Password: postavljena lozinka za navedenu email adresu
Prikaz email postavki na Mikrotiku

Nakon toga, stisni Apply i da vidimo da li sve radi kako treba – stisni Send Email.

Otvorit će se prozor za slanje nove email poruke. U gornjem dijelu ne trebaš išta dirati, već samo ispuni donji dio (To, Subject i Body polja).

Kad stisneš Send Email, ako sve radi kako treba, nakon par sekundi ćeš dobiti email s Mikrotika na adresu koju si naveo. Pripazi da email nije otišao u Spam/Junk folder.

Skripta za update obavijest

Sad kad slanje emaila s Mikrotika radi, možemo ići konfigurirati skriptu koja će se izvršavati.

  1. System > Scheduler te kliknuti na plavi plus da dodamo novu skriptu.
  2. Kod sebe sam stavio da se skripta izvršava svakih 7 dana (odnosno jednom tjedno), no ti za svoje potrebe ovo promjeni u interval koji ti najviše odgovara.

    Postavke:
    • Name: stavi neko svoje ime da znaš o čemu se radi
    • Start Date: početni datum izvršavanja skripte
    • Start Time: vrijeme kada će se na taj dan izvršavati skripta
    • Interval: koliko često će se skripta izvršavati
    • Policy: određuje koja prava skripta može imati. Ovdje sam se igrao da probam ukloniti neke dozvole, no tada mi skripta ne bi radila, stoga sam maknuo samo „dude“ policy, ostalo ostavio.
      Detaljniji opis svih Policy ima u ovom dijelu Mikrotik priručnika.

Izgled same skripte

:local emailAddress "TVOJA EMAIL ADRESA NA KOJU SE ŠALJE"

/system package update
check-for-updates once
:delay 4s;
 
:local currver [get installed-version]
:local newver [get latest-version]
 
:if ( $currver != $newver) do={ 
 
:log info ("A new software update ".$newver." is available. Sending email...")
 
/tool e-mail send to="$emailAddress" subject=("[".[/system identity get name]."] New Firmware available - "  .$newver) body=("A new update is available for your MikroTik device." . "\n" . "Your current version: ".$currver . "\n" . "New version: ".$newver)
}

U prvoj liniji trebaš navesti svoju email adresu na koju ćeš primati obavijesti.

Body skripte sam promijenio prema svojim potrebama, ti slobodno stavi kako ti odgovara izgled poruke.

Izgled skripte na Mikrotiku

Eto ga, to je to.

Kad dođe postavljeno vrijeme, skripta će pogledati ima li nova verzija firmware update-a za Mikrotik. Ako ima, poslat će ti email s obavijesti.

Ako nema, neće se dogoditi ništa i život ide dalje 😋

AUTOR
Hrvoje Matešić

Hrvoje Matešić

PODIJELI ČLANAK
MOGLO BI TE ZANIMATI
PRETPLATI SE
Saznaj kad napišem novi članak
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments